WordPress网站在维护时出现因文件权限不一导致更新失败的解决方法是什么?

在后台更新WordPress插件的时候出现了“更新失败:因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件”的提示

在后台更新WordPress插件的时候出现了“更新失败:因为我们不能复制一些文件,升级未被安装。这通常是因为存在不一致的文件”的提示,导致插件不能更新。那么WordPress网站在维护时出现因文件权限不一导致更新失败的解决方法是什么?

排查原因:曾经出现更新插件需要输入FTP账号的情况,这种情况的产生是文件夹权限不够,按照这个思路区排查更新插件的文件权限,没错啊!都是755。突然发现有些文件的拥有者不同,有些是root,有些是www。

仔细回想了一下,root对应的文件是我从本地上传的(上传时登录用户为root),www是自动下载安装的。

解决方案:既然后台自动安装是www,那么将root的改为www,就可以从后台更新了吧!在PuTTY客户端用cd命令进入网站根目录,然后执行命令chown-Rwwwwp-content/,然后在后台升级。


下载说明:
1. 本站所有资源来源于网络和用户上传,如有侵权请联系站长
2. 本站分享目的仅供大家学习和交流,您必须在下载后24小时内删除!
3. 不得使用于非法商业用途,商用请支持正版!不得违反国家法律,否则后果自负!
6. 本站资源售价只是赞助,收取费用仅维持本站的日常运营所需!

本站的资源均来自于互联网,仅为资源共享、学习参考之目的,其版权均归原作者及其网站所有,如有侵权请留言联系:admin,转转请注明出处:http://zhanmr.com/6405.htm

发表评论

电子邮件地址不会被公开。 必填项已用*标注